Projects
windmill:databases
mongodb
mongodb.spec
Log In
Username
Password
Overview
Repositories
Revisions
Requests
Users
Attributes
Meta
File mongodb.spec of Package mongodb
%define _log_dir %{_var}/log/%{name} %define _home_dir %{_var}/lib/%{name} # %define _home_user %{name} %define _home_group %{name} %define _home_mode 775 # %define _mongodb_user %{name} %define _mongodb_group %{name} %define _mongodb_mode 2511 # BuildRequires: boost-devel gcc-c++ libjs-devel libpcap-devel libstdc++-devel BuildRequires: pcre-devel readline-devel scons BuildRequires: python-devel >= 2.6 # Name: mongodb Version: 1.8.1 Release: 0 # Group: Productivity/Databases/Servers License: AGPLv3 URL: http://www.mongodb.org # Source0: mongodb-src-r%{version}.tar.bz2 Source1: mongodb.init Source2: mongodb.logrotate Source3: mongodb.conf # Patch0: mongodb_cxxflags.patch # BuildRoot: %{_tmppath}/%{name}-%{version}-build # Requires: logrotate %if 0%{?suse_version} PreReq: %{insserv_prereq} %{fillup_prereq} %endif PreReq: /usr/sbin/useradd /usr/sbin/groupadd /usr/sbin/usermod Summary: High-performance, schema-free document-oriented database %description Mongo (from "humongous") is a high-performance, open source, schema-free document-oriented database. MongoDB is written in C++ and offers the following features: * Collection oriented storage: easy storage of object/JSON-style data * Dynamic queries * Full index support, including on inner objects and embedded arrays * Query profiling * Replication and fail-over support * Efficient storage of binary data including large objects (e.g. photos and videos) * Auto-sharding for cloud-level scalability (currently in early alpha) * Commercial Support Available A key goal of MongoDB is to bridge the gap between key/value stores (which are fast and highly scalable) and traditional RDBMS systems (which are deep in functionality). %prep %setup -q -n mongodb-src-r%{version} %patch0 # change dbpath %{__sed} -i 's|/data/db/|/var/lib/%{name}/|' db/pdfile.cpp db/db.cpp %build CPPFLAGS="%{optflags}" \ scons %{?_smp_mflags} --sharedclient --nostrip --pch chmod a-x README GNU-AGPL-3.0.txt %install CPPFLAGS="%{optflags}" \ scons %{?_smp_mflags} install --prefix=%{buildroot}%{_prefix} --sharedclient --nostrip --pch %{__install} -Dd -m 0755 \ %{buildroot}%{_sysconfdir}/init.d \ %{buildroot}%{_sysconfdir}/logrotate.d \ %{buildroot}%{_bindir} \ %{buildroot}%{_libdir} \ %{buildroot}%{_sbindir} %__mv %{buildroot}%{_bindir}/mongod %{buildroot}%{_sbindir} %{__install} -m 0755 libmongoclient.so \ %{buildroot}%{_libdir} # # init script # %{__install} -m 0755 %{S:1} \ %{buildroot}%{_sysconfdir}/init.d/%{name} ln -sf /etc/init.d/%{name} %{buildroot}%{_sbindir}/rc%{name} # # logrotate # %{__install} -m 0644 %{S:2} \ %{buildroot}%{_sysconfdir}/logrotate.d/%{name} # # configuration # %{__install} -m 0644 %{S:3} \ %{buildroot}%{_sysconfdir}/%{name}.conf # # man # mkdir -p %{buildroot}%{_mandir}/man1 %{__install} -m 0644 debian/*.1 %{buildroot}%{_mandir}/man1/ %clean %{__rm} -rf %{buildroot}; %pre # # adding user # /usr/sbin/groupadd -r %{_mongodb_group} >/dev/null 2>/dev/null || : /usr/sbin/useradd -r -o -g %{_mongodb_group} -c "MongoDB database admin" \ -s /bin/false -d %{_home_dir} %{_mongodb_user} 2> /dev/null || : /usr/sbin/usermod -g %{_mongodb_group} -s /bin/false %{_mongodb_user} || : %post /sbin/ldconfig %{fillup_and_insserv -f -y %{name}} %preun %{stop_on_removal %{name}} %postun /sbin/ldconfig %{restart_on_update %{name}} %{insserv_cleanup} %files %defattr(-,root,root,-) %doc README GNU-AGPL-3.0.txt APACHE-2.0.txt %config(noreplace) %{_sysconfdir}/logrotate.d/%{name} %config(noreplace) %{_sysconfdir}/%{name}.conf %{_mandir}/man1/* %{_bindir}/bsondump %{_bindir}/mongo* %{_libdir}/libmongoclient.so %{_sbindir}/mongod %{_sbindir}/rc%{name} %{_initddir}/%{name} %changelog
Locations
Projects
Search
Status Monitor
Help
Open Build Service
OBS Manuals
API Documentation
OBS Portal
Reporting a Bug
Contact
Mailing List
Forums
Chat (IRC)
Twitter
Open Build Service (OBS)
is an
openSUSE project
.